Inbound emails are delayed

Incident Report for 37signals

Resolved

We've resolved the issue with inbound emails being delayed. We'll continue to monitor this closely. So sorry for the interruption today, folks.
Posted Feb 07, 2025 - 16:23 UTC

Identified

We have identified an issue and made a change. The issue with inbound emails is improving, but we're still monitoring the situation. Stay tuned for more updates.
Posted Feb 07, 2025 - 16:08 UTC

Update

We're still investigating the trouble with inbound emails. Stay tuned for updates.
Posted Feb 07, 2025 - 15:59 UTC

Investigating

HEY is having some trouble with inbound emails being delayed. We're looking into the root cause and will keep you posted here. We're so sorry for the interruption, everyone.
Posted Feb 07, 2025 - 15:50 UTC
This incident affected: HEY.