Launchpad is down

Incident Report for 37signals

Resolved

Launchpad is back up! We'll continue to monitor it to make sure it's stable. So sorry for the interruption today, folks.
Posted Mar 31, 2025 - 20:39 UTC

Investigating

Launchpad is currently down. We're investigating the cause and will update you as soon as we can. Sorry for the interruption, everyone.
Posted Mar 31, 2025 - 20:29 UTC